Kapitel 16. Menyer

Innehållsförteckning

1. Introduktion till menyer
1.1. The Image Menu Bar
1.2. Sammanhangsmenyer
1.3. Tear-off menus
1.4. Tab menus
2. The ”File” Menu
2.1. Overview
2.2. New
2.3. Skapa
2.4. Öppna
2.5. Öppna som lager
2.6. Öppna plats
2.7. Open Recent
2.8. Spara
2.9. Spara som
2.10. Spara en kopia
2.11. Revert
2.12. Export
2.13. Export As...
2.14. Create Template
2.15. Skriv ut
2.16. Stäng
2.17. Stäng alla
2.18. Avsluta
3. The ”Edit” Menu
3.1. ”Edit” Menu Entries
3.2. Ångra
3.3. Gör om
3.4. Fade
3.5. Ångringshistorik
3.6. Klipp ut
3.7. Kopiera
3.8. Kopiera synlig
3.9. Klistra in
3.10. Paste Into
3.11. Paste as
3.12. Buffert
3.13. Töm
3.14. Fyll med förgrundsfärg
3.15. Fyll med bakgrundsfärg
3.16. Fyll med mönster
3.17. Stroke Selection
3.18. Stroke Path
3.19. The ”Preferences” Command
3.20. Tangentbordsgenvägar
3.21. Modules
3.22. Enheter
4. The ”Select” Menu
4.1. Introduction to the ”Select” Menu
4.2. Markera allt
4.3. None
4.4. Invertera
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Distort
4.15. Rounded Rectangle
4.16. Toggle QuickMask
4.17. Spara till kanal
4.18. To Path
5. The ”View” Menu
5.1. Introduction to the ”View” Menu
5.2. Ny vy
5.3. Punkt för punkt
5.4. Zooma
5.5. Shrink Wrap
5.6. Helskärm
5.7. Navigeringsfönster
5.8. Visningsfilter
5.9. Visa markering
5.10. Show Layer Boundary
5.11. Visa hjälplinjer
5.12. Visa rutnät
5.13. Visa samplingspunkter
5.14. Fäst mot hjälplinjer
5.15. Fäst mot rutnät
5.16. Snap to Canvas
5.17. Snap to Active Path
5.18. Padding Color
5.19. Visa menyrad
5.20. Visa linjaler
5.21. Visa rullningslister
5.22. Visa statusrad
6. The ”Image” Menu
6.1. Overview
6.2. Duplicate
6.3. Läge
6.4. RGB-läge
6.5. Grayscale mode
6.6. Indexed mode
6.7. Transformera
6.8. Flip Horizontally; Flip Vertically
6.9. Rotation
6.10. Guillotine
6.11. Canvas Size
6.12. Fit Canvas to Layers
6.13. Fit Canvas to Selection
6.14. Print Size
6.15. Skala bild
6.16. Beskär till markering
6.17. Autocrop Image
6.18. Zealous Crop
6.19. Sammanfoga synliga lager
6.20. Flatten Image
6.21. Align Visible Layers
6.22. Hjälplinjer
6.23. Ny hjälplinje
6.24. New Guide (by Percent)
6.25. New Guides from Selection
6.26. Ta bort alla hjälplinjer
6.27. Configure Grid
6.28. Bildegenskaper
7. The ”Layer” Menu
7.1. Introduction to the ”Layer” Menu
7.2. Nytt lager
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Förankra lager
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Förkasta textinformation
7.11. ”Stack” Submenu
7.12. Select Previous Layer
7.13. Välj nästa lager
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Höj lager
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The ”Reverse Layer Order” command
7.21. The ”Mask” Submenu
7.22. Lägg till lagermask
7.23. Tillämpa lagermask
7.24. Ta bort lagermask
7.25. Visa lagermask
7.26. Redigera lagermask
7.27. Inaktivera lagermask
7.28. Mask till markering
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The ”Transparency” Submenu of the ”Layer” menu
7.33. Lägg till alfakanal
7.34. Ta bort alfakanal
7.35. Färg till alfa
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The ”Transform” Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Beskär till markering
7.54. Autocrop Layer
8. The ”Colors” Menu
8.1. Introduction to the ”Colors” Menu
8.2. Färgverktyg
8.3. Invertera
8.4. Value Invert
8.5. Använd GEGL
8.6. The ”Auto” Submenu
8.7. Equalize
8.8. Vitbalans
8.9. Color Enhance
8.10. Normalisera
8.11. Stretch Contrast
8.12. Stretch HSV
8.13. The ”Components” Submenu
8.14. Channel Mixer
8.15. Compose
8.16. Decompose
8.17. Recompose
8.18. The ”Map” Submenu
8.19. Rearrange Colormap
8.20. Set Colormap
8.21. Alien Map
8.22. Color Exchange
8.23. Gradient Map
8.24. Palette Map
8.25. Rotate Colors
8.26. Sample Colorize
8.27. The ”Info” Submenu
8.28. Histogram
8.29. Border Average
8.30. Colorcube Analysis
8.31. Smooth Palette
8.32. The Color Filters
8.33. Färglägg
8.34. Färg till alfa
8.35. Filter Pack
8.36. Hot
8.37. Max RGB
8.38. Retinex
9. The ”Tools” Menu
9.1. Introduction to the ”Tools” Menu
10. The ”Filters” Menu
10.1. Introduction to the ”Filters” Menu
10.2. Upprepa senaste
10.3. Re-show Last
10.4. Reset All Filters
10.5. The ”Python-Fu” Submenu
10.6. Undermenyn ”Script-Fu”
11. ”Windows” Menu
12. ”Hjälp”-menyn
12.1. Introduktion till ”Hjälp”-menyn
12.2. Hjälp
12.3. Sammanhangshjälp
12.4. Dagens tips
12.5. Om
12.6. Insticksbläddrare
12.7. Procedurbläddrare
12.8. GIMP på nätet

1. Introduktion till menyer

There are many places in GIMP where you can find menus. The aim of this chapter is to explain all the commands that are accessible from the image menu bar and the image menu you can get by right clicking in the canvas. All the context menus and the menu entries for the other dialogs are described elsewhere in the chapters that describe the dialogs themselves.

1.1. The Image Menu Bar

This menu bar may contain other entries if you have added script-fus, python-fus or videos to your GIMP.

1.2. Sammanhangsmenyer

If you right-click on certain parts of the GIMP interface, a ”context menu” opens, which leads to a variety of functions. Some places where you can access context menus are:

  • Clicking on an image window displays the Image menu. This is useful when you are working in full-screen mode, without a menubar.

  • Clicking on a layer in the Layers Dialog or on a channel in the Channels Dialog displays functions for the selected layer or channel.

  • Right-clicking on the image menubar has the same effect as left-clicking.

  • Right-clicking on the title bar displays functions which do not belong to GIMP, but to the window manager program on your computer.

1.3. Tear-off menus

There is an interesting property associated with some of the menus in GIMP. These are any of the menus from the Image context menu you get by right-clicking on the canvas and any of its submenus. (You can tell that a menu item leads to a submenu because there is an icon next to it.) When you bring up any of these menus, there is a dotted line at the top of it (tear-off line). By clicking on this dotted line, you detach the menu under it and it becomes a separate window.

Figur 16.1. The ”windows” submenu and its tear-off submenu

The ”windows” submenu and its tear-off submenu
The ”windows” submenu and its tear-off submenu

Tear-off menus are actually independent. They are always visible, their functions always apply to the current image, and they persist when all of the images are closed. You can close a tear-off submenu by clicking on the dotted line again or closing the window from the window manager on your computer (often by clicking on an X icon in the upper right corner of the window).

These tear-off submenus are also created in single-window mode, but are of less interest since they are masked by the window as soon as you click on it.

1.4. Tab menus

The following type of menus is not related to the image menu bar, but for the sake of completeness:

Every dockable dialog contains a Tab Menu button, as highlighted below. Pressing this Tab Menu button opens a special menu of tab-related operations, with an entry at the top that opens into the dialog's context menu.

Figur 16.2. A dockable dialog.

A dockable dialog.

A dialog window with the Tab menu button highlighted.

A dockable dialog.

The Tab menu.


See Avsnitt 2.3.2, ”Flikmeny” to learn more about Tab menus.